aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-01-13 14:55:07 +0000
committerJonas Gorski <jogo@openwrt.org>2012-01-13 14:55:07 +0000
commitb49e97601bba8ba4075085b69e00952373e18af2 (patch)
tree322fc313a19bc903c788a7acf9b6fabef06b04e5 /target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch
parentef7ec19360f373ead4bffc66c10fd70ec6c1aa78 (diff)
downloadmaster-187ad058-b49e97601bba8ba4075085b69e00952373e18af2.tar.gz
master-187ad058-b49e97601bba8ba4075085b69e00952373e18af2.tar.bz2
master-187ad058-b49e97601bba8ba4075085b69e00952373e18af2.zip
kernel: add support for linux 3.2.1
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29730 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..f22bd4ccd4
--- /dev/null
+++ b/target/linux/generic/patches-3.2/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -923,3 +923,6 @@ config CRYPTO_USER_API_SKCIPHER
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -91,6 +91,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
+ obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
+ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #