aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.2/201-extra_optimization.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-27 15:01:37 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-27 15:01:37 +0000
commit4f1451b47e0483c21393b13f82d5eb24d3fb17f2 (patch)
treec3e80a16d0b4070af1ea473d644981d1df410c54 /target/linux/generic/patches-3.2/201-extra_optimization.patch
parent7e71e51d60fc258c9c4cb2dc07ad9c3736c59a66 (diff)
downloadmaster-187ad058-4f1451b47e0483c21393b13f82d5eb24d3fb17f2.tar.gz
master-187ad058-4f1451b47e0483c21393b13f82d5eb24d3fb17f2.tar.bz2
master-187ad058-4f1451b47e0483c21393b13f82d5eb24d3fb17f2.zip
linux/3.2: R.I.P.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31905 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.2/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-3.2/201-extra_optimization.patch24
1 files changed, 0 insertions, 24 deletions
diff --git a/target/linux/generic/patches-3.2/201-extra_optimization.patch b/target/linux/generic/patches-3.2/201-extra_optimization.patch
deleted file mode 100644
index 6fe8b0938d..0000000000
--- a/target/linux/generic/patches-3.2/201-extra_optimization.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -559,9 +559,9 @@ endif # $(dot-config)
- all: vmlinux
-
- ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
--KBUILD_CFLAGS += -Os
-+KBUILD_CFLAGS += -Os -fno-caller-saves
- else
--KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
- endif
-
- include $(srctree)/arch/$(SRCARCH)/Makefile
-@@ -620,6 +620,9 @@ endif
- NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
- CHECKFLAGS += $(NOSTDINC_FLAGS)
-
-+# improve gcc optimization
-+CFLAGS += $(call cc-option,-funit-at-a-time,)
-+
- # warn about C99 declaration after statement
- KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
-