aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.19/723-phy_ip175c.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
commiteac842c52b28a4fd42082f3ca8231f5874a57361 (patch)
tree514eb8ba16df65dd4b3feeb3c900279596556d09 /target/linux/generic/patches-3.19/723-phy_ip175c.patch
parent10c00d28433d42305ead73480465ce87d047a3d2 (diff)
downloadmaster-187ad058-eac842c52b28a4fd42082f3ca8231f5874a57361.tar.gz
master-187ad058-eac842c52b28a4fd42082f3ca8231f5874a57361.tar.bz2
master-187ad058-eac842c52b28a4fd42082f3ca8231f5874a57361.zip
generic: add preliminary 3.19 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44126 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.19/723-phy_ip175c.patch')
-rw-r--r--target/linux/generic/patches-3.19/723-phy_ip175c.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.19/723-phy_ip175c.patch b/target/linux/generic/patches-3.19/723-phy_ip175c.patch
new file mode 100644
index 0000000000..c8e1dcb88f
--- /dev/null
+++ b/target/linux/generic/patches-3.19/723-phy_ip175c.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -143,6 +143,10 @@ config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
+ select ETHERNET_PACKET_MANGLE
+
++config IP17XX_PHY
++ tristate "Driver for IC+ IP17xx switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ tristate "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -20,6 +20,7 @@ obj-$(CONFIG_BCM87XX_PHY) += bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
++obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed_phy.o