aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2014-10-27 18:14:39 +0000
committerRafał Miłecki <zajec5@gmail.com>2014-10-27 18:14:39 +0000
commit1c45c113c4aee13ca5a5cc30f357d2072a14b5e7 (patch)
tree89a6f12673d11ed2a89ac083a6c93ce47dad831c /target/linux/generic/patches-3.18/940-ocf_kbuild_integration.patch
parentac7e9e859bb08a7d8a9c82bed1d08abbf57b5ace (diff)
downloadmaster-187ad058-1c45c113c4aee13ca5a5cc30f357d2072a14b5e7.tar.gz
master-187ad058-1c45c113c4aee13ca5a5cc30f357d2072a14b5e7.tar.bz2
master-187ad058-1c45c113c4aee13ca5a5cc30f357d2072a14b5e7.zip
kernel: start working on 3.18 support
This commit: 1) Copies 3.14 patches 2) Drops mainlined stuff 3) Modifies some patches to apply Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43093 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.18/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-3.18/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.18/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-3.18/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..240f15eb61
--- /dev/null
+++ b/target/linux/generic/patches-3.18/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1519,3 +1519,6 @@ source "drivers/crypto/Kconfig"
+ source crypto/asymmetric_keys/Kconfig
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -101,6 +101,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
+ obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
+ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #