aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18/904-debloat_dma_buf.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-19 21:09:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-19 21:09:11 +0000
commitc263294d2814812292e46fbfc04c082ebbfc1812 (patch)
treecd1b3d4b4e8d8441f832592ca2e46bffe468b186 /target/linux/generic/patches-3.18/904-debloat_dma_buf.patch
parent086445645cb21404be4a8773be875a33779c6454 (diff)
downloadmaster-187ad058-c263294d2814812292e46fbfc04c082ebbfc1812.tar.gz
master-187ad058-c263294d2814812292e46fbfc04c082ebbfc1812.tar.bz2
master-187ad058-c263294d2814812292e46fbfc04c082ebbfc1812.zip
kernel: modularize dma shared buffer code to eliminate kernel bloat
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48371 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.18/904-debloat_dma_buf.patch')
-rw-r--r--target/linux/generic/patches-3.18/904-debloat_dma_buf.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.18/904-debloat_dma_buf.patch b/target/linux/generic/patches-3.18/904-debloat_dma_buf.patch
new file mode 100644
index 0000000000..dc6a3b93dc
--- /dev/null
+++ b/target/linux/generic/patches-3.18/904-debloat_dma_buf.patch
@@ -0,0 +1,35 @@
+--- a/drivers/base/Kconfig
++++ b/drivers/base/Kconfig
+@@ -229,7 +229,7 @@ config SOC_BUS
+ source "drivers/base/regmap/Kconfig"
+
+ config DMA_SHARED_BUFFER
+- bool
++ tristate
+ default n
+ select ANON_INODES
+ help
+--- a/drivers/dma-buf/Makefile
++++ b/drivers/dma-buf/Makefile
+@@ -1 +1,2 @@
+-obj-y := dma-buf.o fence.o reservation.o seqno-fence.o
++obj-$(CONFIG_DMA_SHARED_BUFFER) := dma-shared-buffer.o
++dma-shared-buffer-objs := dma-buf.o fence.o reservation.o seqno-fence.o
+--- a/drivers/dma-buf/dma-buf.c
++++ b/drivers/dma-buf/dma-buf.c
+@@ -904,4 +904,4 @@ static void __exit dma_buf_deinit(void)
+ {
+ dma_buf_uninit_debugfs();
+ }
+-__exitcall(dma_buf_deinit);
++module_exit(dma_buf_deinit);
+--- a/kernel/sched/core.c
++++ b/kernel/sched/core.c
+@@ -1801,6 +1801,7 @@ int wake_up_state(struct task_struct *p,
+ {
+ return try_to_wake_up(p, state, 0);
+ }
++EXPORT_SYMBOL_GPL(wake_up_state);
+
+ /*
+ * This function clears the sched_dl_entity static params.