aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18/615-netfilter_add_xt_id_match.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-09 11:01:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-09 11:01:49 +0000
commitce28e880c9bdb5725d6dedf7efdb7bd4970361d1 (patch)
treef9ab92a2850465df05e114d61c466211fcdca0b4 /target/linux/generic/patches-3.18/615-netfilter_add_xt_id_match.patch
parentffadf07c00574431744208b71ba1219f698c14c5 (diff)
downloadmaster-187ad058-ce28e880c9bdb5725d6dedf7efdb7bd4970361d1.tar.gz
master-187ad058-ce28e880c9bdb5725d6dedf7efdb7bd4970361d1.tar.bz2
master-187ad058-ce28e880c9bdb5725d6dedf7efdb7bd4970361d1.zip
kernel: add a patch to make netfilter conntrack cache routing information
Significantly improves routing / NAT performance Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43587 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.18/615-netfilter_add_xt_id_match.patch')
-rw-r--r--target/linux/generic/patches-3.18/615-netfilter_add_xt_id_match.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/generic/patches-3.18/615-netfilter_add_xt_id_match.patch b/target/linux/generic/patches-3.18/615-netfilter_add_xt_id_match.patch
index 265ff207b6..cbb9b2b8bd 100644
--- a/target/linux/generic/patches-3.18/615-netfilter_add_xt_id_match.patch
+++ b/target/linux/generic/patches-3.18/615-netfilter_add_xt_id_match.patch
@@ -21,7 +21,7 @@
+#endif /* XT_ID_H */
--- a/net/netfilter/Kconfig
+++ b/net/netfilter/Kconfig
-@@ -1145,6 +1145,13 @@ config NETFILTER_XT_MATCH_IPCOMP
+@@ -1157,6 +1157,13 @@ config NETFILTER_XT_MATCH_IPCOMP
To compile it as a module, choose M here. If unsure, say N.
@@ -37,7 +37,7 @@
depends on NETFILTER_ADVANCED
--- a/net/netfilter/Makefile
+++ b/net/netfilter/Makefile
-@@ -140,6 +140,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_ESP) +=
+@@ -143,6 +143,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_ESP) +=
obj-$(CONFIG_NETFILTER_XT_MATCH_HASHLIMIT) += xt_hashlimit.o
obj-$(CONFIG_NETFILTER_XT_MATCH_HELPER) += xt_helper.o
obj-$(CONFIG_NETFILTER_XT_MATCH_HL) += xt_hl.o