aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18/259-regmap_dynamic.patch
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2014-10-27 18:14:39 +0000
committerRafał Miłecki <zajec5@gmail.com>2014-10-27 18:14:39 +0000
commit1c45c113c4aee13ca5a5cc30f357d2072a14b5e7 (patch)
tree89a6f12673d11ed2a89ac083a6c93ce47dad831c /target/linux/generic/patches-3.18/259-regmap_dynamic.patch
parentac7e9e859bb08a7d8a9c82bed1d08abbf57b5ace (diff)
downloadmaster-187ad058-1c45c113c4aee13ca5a5cc30f357d2072a14b5e7.tar.gz
master-187ad058-1c45c113c4aee13ca5a5cc30f357d2072a14b5e7.tar.bz2
master-187ad058-1c45c113c4aee13ca5a5cc30f357d2072a14b5e7.zip
kernel: start working on 3.18 support
This commit: 1) Copies 3.14 patches 2) Drops mainlined stuff 3) Modifies some patches to apply Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43093 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.18/259-regmap_dynamic.patch')
-rw-r--r--target/linux/generic/patches-3.18/259-regmap_dynamic.patch76
1 files changed, 76 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.18/259-regmap_dynamic.patch b/target/linux/generic/patches-3.18/259-regmap_dynamic.patch
new file mode 100644
index 0000000000..e7f5bcee97
--- /dev/null
+++ b/target/linux/generic/patches-3.18/259-regmap_dynamic.patch
@@ -0,0 +1,76 @@
+--- a/drivers/base/regmap/Kconfig
++++ b/drivers/base/regmap/Kconfig
+@@ -3,23 +3,28 @@
+ # subsystems should select the appropriate symbols.
+
+ config REGMAP
+- default y if (REGMAP_I2C || REGMAP_SPI || REGMAP_SPMI || REGMAP_MMIO || REGMAP_IRQ)
+ select LZO_COMPRESS
+ select LZO_DECOMPRESS
+ select IRQ_DOMAIN if REGMAP_IRQ
+- bool
++ tristate "Regmap"
+
+ config REGMAP_I2C
+- tristate
++ select REGMAP
++ tristate "Regmap I2C
+
+ config REGMAP_SPI
+- tristate
++ select REGMAP
++ depends on SPI_MASTER
++ tristate "Regmap SPI"
+
+ config REGMAP_SPMI
++ select REGMAP
+ tristate
+
+ config REGMAP_MMIO
++ select REGMAP
+ tristate
+
+ config REGMAP_IRQ
++ select REGMAP
+ bool
+--- a/include/linux/regmap.h
++++ b/include/linux/regmap.h
+@@ -49,7 +49,7 @@ struct reg_default {
+ unsigned int def;
+ };
+
+-#ifdef CONFIG_REGMAP
++#if IS_ENABLED(CONFIG_REGMAP)
+
+ enum regmap_endian {
+ /* Unspecified -> 0 -> Backwards compatible default */
+--- a/drivers/base/regmap/Makefile
++++ b/drivers/base/regmap/Makefile
+@@ -1,6 +1,8 @@
+-obj-$(CONFIG_REGMAP) += regmap.o regcache.o
+-obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o regcache-flat.o
+-obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
++regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o regcache-flat.o
++ifdef CONFIG_DEBUG_FS
++regmap-core-objs += regmap-debugfs.o
++endif
++obj-$(CONFIG_REGMAP) += regmap-core.o
+ obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
+ obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
+ obj-$(CONFIG_REGMAP_SPMI) += regmap-spmi.o
+--- a/drivers/base/regmap/regmap.c
++++ b/drivers/base/regmap/regmap.c
+@@ -13,6 +13,7 @@
+ #include <linux/device.h>
+ #include <linux/slab.h>
+ #include <linux/export.h>
++#include <linux/module.h>
+ #include <linux/mutex.h>
+ #include <linux/err.h>
+ #include <linux/rbtree.h>
+@@ -2247,3 +2248,5 @@ static int __init regmap_initcall(void)
+ return 0;
+ }
+ postcore_initcall(regmap_initcall);
++
++MODULE_LICENSE("GPL");