aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/724-phy_ar8216.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
commit2b43bb49dec4546cdca7e627b06e7682ae742591 (patch)
tree0d58c3ccdefbe53983cda5399612b4727f0ee81d /target/linux/generic/patches-3.14/724-phy_ar8216.patch
parent3be7023c9be4e1381699ce393638ad63565c9ac5 (diff)
downloadmaster-187ad058-2b43bb49dec4546cdca7e627b06e7682ae742591.tar.gz
master-187ad058-2b43bb49dec4546cdca7e627b06e7682ae742591.tar.bz2
master-187ad058-2b43bb49dec4546cdca7e627b06e7682ae742591.zip
add preliminary 3.14 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39789 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.14/724-phy_ar8216.patch')
-rw-r--r--target/linux/generic/patches-3.14/724-phy_ar8216.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/724-phy_ar8216.patch b/target/linux/generic/patches-3.14/724-phy_ar8216.patch
new file mode 100644
index 0000000000..d3b238efce
--- /dev/null
+++ b/target/linux/generic/patches-3.14/724-phy_ar8216.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -135,6 +135,11 @@ config IP17XX_PHY
+ tristate "Driver for IC+ IP17xx switches"
+ select SWCONFIG
+
++config AR8216_PHY
++ tristate "Driver for Atheros AR8216 switches"
++ select ETHERNET_PACKET_MANGLE
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -21,6 +21,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
++obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o