aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
commit2b43bb49dec4546cdca7e627b06e7682ae742591 (patch)
tree0d58c3ccdefbe53983cda5399612b4727f0ee81d /target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
parent3be7023c9be4e1381699ce393638ad63565c9ac5 (diff)
downloadmaster-187ad058-2b43bb49dec4546cdca7e627b06e7682ae742591.tar.gz
master-187ad058-2b43bb49dec4546cdca7e627b06e7682ae742591.tar.bz2
master-187ad058-2b43bb49dec4546cdca7e627b06e7682ae742591.zip
add preliminary 3.14 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39789 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch')
-rw-r--r--target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch b/target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
new file mode 100644
index 0000000000..02697f64eb
--- /dev/null
+++ b/target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -48,6 +48,12 @@ config MTD_SPLIT_SQUASHFS_ROOT
+ offset and size of the unused portion of a rootfs partition
+ containing a squashfs.
+
++comment "Firmware partition parsers"
++
++config MTD_SPLIT_UIMAGE_FW
++ bool "uImage based firmware partition parser"
++ select MTD_SPLIT
++
+ config MTD_SPLIT
+ def_bool n
+ help
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o mtdconc
+
+ mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
+ mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
++mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
+
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o