aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-08-25 16:30:44 +0000
committerJohn Crispin <blogic@openwrt.org>2014-08-25 16:30:44 +0000
commit028ad9f1cdee8e67a2d4a52c938f0a77ab9aed3d (patch)
tree62952ac40091c42bba43abaa8b5369f53950b3e6 /target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch
parent6894492f815707d79c825d04074957412f8cb2aa (diff)
downloadmaster-187ad058-028ad9f1cdee8e67a2d4a52c938f0a77ab9aed3d.tar.gz
master-187ad058-028ad9f1cdee8e67a2d4a52c938f0a77ab9aed3d.tar.bz2
master-187ad058-028ad9f1cdee8e67a2d4a52c938f0a77ab9aed3d.zip
kernel: add own Kconfig for OpenWrt mtdsplit drivers
There are pretty many OpenWrt patches against mtd subsystem resulting in a bit of mess and growing maintenance cost. My idea is to use an extra "mtdsplit" directory with OpenWrt specific files (including Kconfig). This is the first step to achieve this. This patch adds a "mtdsplit" directory with Kconfig and replaces 4 patches with a single one. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42287 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch')
-rw-r--r--target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch b/target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch
new file mode 100644
index 0000000000..eac31d7420
--- /dev/null
+++ b/target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -37,6 +37,8 @@ config MTD_UIMAGE_SPLIT
+ depends on MTD_SPLIT_FIRMWARE
+ default y
+
++source "drivers/mtd/mtdsplit/Kconfig"
++
+ config MTD_SPLIT
+ def_bool n
+ help
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -7,6 +7,10 @@ obj-$(CONFIG_MTD) += mtd.o
+ mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
+
+ mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
++mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
++mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
++mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
++mtd-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
+
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o