aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.13/830-ledtrig_morse.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
commit11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c (patch)
treeec4fe2ab7f765c6d86d6b321349f296dbc9afb9b /target/linux/generic/patches-3.13/830-ledtrig_morse.patch
parent54d11602cc5a312834e38e09158ac55cc3429a86 (diff)
downloadmaster-187ad058-11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c.tar.gz
master-187ad058-11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c.tar.bz2
master-187ad058-11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c.zip
[generic]: add initial 3.13 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39348 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.13/830-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-3.13/830-ledtrig_morse.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.13/830-ledtrig_morse.patch b/target/linux/generic/patches-3.13/830-ledtrig_morse.patch
new file mode 100644
index 0000000000..a5dffd2d9a
--- /dev/null
+++ b/target/linux/generic/patches-3.13/830-ledtrig_morse.patch
@@ -0,0 +1,28 @@
+--- a/drivers/leds/trigger/Kconfig
++++ b/drivers/leds/trigger/Kconfig
+@@ -108,4 +108,8 @@ config LEDS_TRIGGER_CAMERA
+ This enables direct flash/torch on/off by the driver, kernel space.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -60,3 +60,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
+
+ # LED Triggers
+ obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+--- a/drivers/leds/ledtrig-morse.c
++++ b/drivers/leds/ledtrig-morse.c
+@@ -26,7 +26,6 @@
+ #include <linux/list.h>
+ #include <linux/spinlock.h>
+ #include <linux/device.h>
+-#include <linux/sysdev.h>
+ #include <linux/timer.h>
+ #include <linux/ctype.h>
+ #include <linux/leds.h>