aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.13/725-phy_rtl8306.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
commit11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c (patch)
treeec4fe2ab7f765c6d86d6b321349f296dbc9afb9b /target/linux/generic/patches-3.13/725-phy_rtl8306.patch
parent54d11602cc5a312834e38e09158ac55cc3429a86 (diff)
downloadmaster-187ad058-11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c.tar.gz
master-187ad058-11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c.tar.bz2
master-187ad058-11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c.zip
[generic]: add initial 3.13 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39348 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.13/725-phy_rtl8306.patch')
-rw-r--r--target/linux/generic/patches-3.13/725-phy_rtl8306.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.13/725-phy_rtl8306.patch b/target/linux/generic/patches-3.13/725-phy_rtl8306.patch
new file mode 100644
index 0000000000..56899a70ba
--- /dev/null
+++ b/target/linux/generic/patches-3.13/725-phy_rtl8306.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -140,6 +140,10 @@ config AR8216_PHY
+ select ETHERNET_PACKET_MANGLE
+ select SWCONFIG
+
++config RTL8306_PHY
++ tristate "Driver for Realtek RTL8306S switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -22,6 +22,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
++obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o