aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.13/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
commit11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c (patch)
treeec4fe2ab7f765c6d86d6b321349f296dbc9afb9b /target/linux/generic/patches-3.13/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
parent54d11602cc5a312834e38e09158ac55cc3429a86 (diff)
downloadmaster-187ad058-11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c.tar.gz
master-187ad058-11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c.tar.bz2
master-187ad058-11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c.zip
[generic]: add initial 3.13 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39348 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.13/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch')
-rw-r--r--target/linux/generic/patches-3.13/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.13/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch b/target/linux/generic/patches-3.13/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
new file mode 100644
index 0000000000..02697f64eb
--- /dev/null
+++ b/target/linux/generic/patches-3.13/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -48,6 +48,12 @@ config MTD_SPLIT_SQUASHFS_ROOT
+ offset and size of the unused portion of a rootfs partition
+ containing a squashfs.
+
++comment "Firmware partition parsers"
++
++config MTD_SPLIT_UIMAGE_FW
++ bool "uImage based firmware partition parser"
++ select MTD_SPLIT
++
+ config MTD_SPLIT
+ def_bool n
+ help
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o mtdconc
+
+ mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
+ mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
++mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
+
+ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o