aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-16 18:31:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-16 18:31:05 +0000
commitc19a05ddc769a8b14837218fea04fe8b5c887eee (patch)
treed0285c3b8b16f40ed39ca88a77e257f6443ecb57 /target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch
parent80a4ffa1e2bc5f3ef893251babb2371c502f04ad (diff)
downloadmaster-187ad058-c19a05ddc769a8b14837218fea04fe8b5c887eee.tar.gz
master-187ad058-c19a05ddc769a8b14837218fea04fe8b5c887eee.tar.bz2
master-187ad058-c19a05ddc769a8b14837218fea04fe8b5c887eee.zip
kernel: reorganize 2.6.39 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26691 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch b/target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch
new file mode 100644
index 0000000000..2edc4f33cb
--- /dev/null
+++ b/target/linux/generic/patches-2.6.39/830-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -449,4 +449,8 @@ config LEDS_TRIGGER_DEFAULT_ON
+ comment "iptables trigger is under Netfilter config (LED target)"
+ depends on LEDS_TRIGGERS
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -53,3 +53,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o