aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.39/201-extra_optimization.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-16 18:31:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-16 18:31:05 +0000
commitc19a05ddc769a8b14837218fea04fe8b5c887eee (patch)
treed0285c3b8b16f40ed39ca88a77e257f6443ecb57 /target/linux/generic/patches-2.6.39/201-extra_optimization.patch
parent80a4ffa1e2bc5f3ef893251babb2371c502f04ad (diff)
downloadmaster-187ad058-c19a05ddc769a8b14837218fea04fe8b5c887eee.tar.gz
master-187ad058-c19a05ddc769a8b14837218fea04fe8b5c887eee.tar.bz2
master-187ad058-c19a05ddc769a8b14837218fea04fe8b5c887eee.zip
kernel: reorganize 2.6.39 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26691 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.39/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-2.6.39/201-extra_optimization.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.39/201-extra_optimization.patch b/target/linux/generic/patches-2.6.39/201-extra_optimization.patch
new file mode 100644
index 0000000000..8039c66523
--- /dev/null
+++ b/target/linux/generic/patches-2.6.39/201-extra_optimization.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -543,9 +543,9 @@ endif # $(dot-config)
+ all: vmlinux
+
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+-KBUILD_CFLAGS += -Os
++KBUILD_CFLAGS += -Os -fno-caller-saves
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+@@ -600,6 +600,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+