aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.38/400-ledtrig_morse.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-01-21 17:52:22 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-01-21 17:52:22 +0000
commit2a7bdb2ef04b744e08d54e65e2cd76780a71aa34 (patch)
tree7b8643b5144db15c53536abf69dec2a49aa31bef /target/linux/generic/patches-2.6.38/400-ledtrig_morse.patch
parent318102d24a60f6442052508c391aa984c5dbf97c (diff)
downloadmaster-187ad058-2a7bdb2ef04b744e08d54e65e2cd76780a71aa34.tar.gz
master-187ad058-2a7bdb2ef04b744e08d54e65e2cd76780a71aa34.tar.bz2
master-187ad058-2a7bdb2ef04b744e08d54e65e2cd76780a71aa34.zip
[target/generic]: preliminary 2.6.38 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25057 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.38/400-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-2.6.38/400-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.38/400-ledtrig_morse.patch b/target/linux/generic/patches-2.6.38/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..8d90184556
--- /dev/null
+++ b/target/linux/generic/patches-2.6.38/400-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -439,4 +439,8 @@ config LEDS_TRIGGER_DEFAULT_ON
+ comment "iptables trigger is under Netfilter config (LED target)"
+ depends on LEDS_TRIGGERS
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -52,3 +52,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o