aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.37/970-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-03 16:13:33 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-03 16:13:33 +0000
commit76cfba7b8c6b079ff6c658f6bd41a8b3b4f45bf0 (patch)
treee173de5498db08719c81621c36a6bbbdb0c67eb0 /target/linux/generic/patches-2.6.37/970-ocf_kbuild_integration.patch
parent208df9da51b8ff30c79828d50c934ada4f580764 (diff)
downloadmaster-187ad058-76cfba7b8c6b079ff6c658f6bd41a8b3b4f45bf0.tar.gz
master-187ad058-76cfba7b8c6b079ff6c658f6bd41a8b3b4f45bf0.tar.bz2
master-187ad058-76cfba7b8c6b079ff6c658f6bd41a8b3b4f45bf0.zip
target/linux: add preliminary 2.6.37 kernel support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23828 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.37/970-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-2.6.37/970-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.37/970-ocf_kbuild_integration.patch b/target/linux/generic/patches-2.6.37/970-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..484f75aeb8
--- /dev/null
+++ b/target/linux/generic/patches-2.6.37/970-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -848,3 +848,6 @@ config CRYPTO_ANSI_CPRNG
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -86,6 +86,8 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+ obj-$(CONFIG_CRYPTO_GHASH) += ghash-generic.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #