aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-25 23:47:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-25 23:47:04 +0000
commit21eafc2aa4f4380ce06e1d75f1125113b7d4b793 (patch)
tree4bb353248c047e0a4e72ff4b60d68a015ea19bea /target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch
parent614123e8019c30ca542ea26d7c9088745814435c (diff)
downloadmaster-187ad058-21eafc2aa4f4380ce06e1d75f1125113b7d4b793.tar.gz
master-187ad058-21eafc2aa4f4380ce06e1d75f1125113b7d4b793.tar.bz2
master-187ad058-21eafc2aa4f4380ce06e1d75f1125113b7d4b793.zip
kernel: remove all local symbols from kernel modules at link time to reduce their size
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26298 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch')
-rw-r--r--target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch b/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch
new file mode 100644
index 0000000000..2e2508125d
--- /dev/null
+++ b/target/linux/generic/patches-2.6.37/015-strip_module_local_symbols.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -360,7 +360,7 @@
+ KBUILD_AFLAGS := -D__ASSEMBLY__
+ KBUILD_AFLAGS_MODULE := -DMODULE
+ KBUILD_CFLAGS_MODULE := -DMODULE
+-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
++KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds -x
+
+ # Read KERNELRELEASE from include/config/kernel.release (if it exists)
+ KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)