aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.36
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-12-17 17:10:11 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-12-17 17:10:11 +0000
commit21a4f56bc642031d2dd5b84bdb21b378fc0964ba (patch)
treefb4ef39b00428d6bd9354ce4ac3f84d967cac8d5 /target/linux/generic/patches-2.6.36
parent4d67ce00923b081ab4138aff86f23a07ce303ff8 (diff)
downloadmaster-187ad058-21a4f56bc642031d2dd5b84bdb21b378fc0964ba.tar.gz
master-187ad058-21a4f56bc642031d2dd5b84bdb21b378fc0964ba.tar.bz2
master-187ad058-21a4f56bc642031d2dd5b84bdb21b378fc0964ba.zip
generic: add LED trigger for USB device presence/activity
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24646 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.36')
-rw-r--r--target/linux/generic/patches-2.6.36/403-ledtrig-usbdev.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.36/403-ledtrig-usbdev.patch b/target/linux/generic/patches-2.6.36/403-ledtrig-usbdev.patch
new file mode 100644
index 0000000000..fe334d5ed1
--- /dev/null
+++ b/target/linux/generic/patches-2.6.36/403-ledtrig-usbdev.patch
@@ -0,0 +1,21 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -391,4 +391,11 @@ config LEDS_TRIGGER_NETDEV
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_USBDEV
++ tristate "LED USB device Trigger"
++ depends on USB && LEDS_TRIGGERS
++ help
++ This allows LEDs to be controlled by the presence/activity of
++ an USB device. If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -51,3 +51,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
++obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o