aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.35/991-ppc4xx_optimization.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
commita082943b09f4f707990ad0ac6326df8480507f02 (patch)
treede32e4def600e56134cd085a7447cb6620542078 /target/linux/generic/patches-2.6.35/991-ppc4xx_optimization.patch
parent67fbcc7bd42cc07b1f3c6b5c9f2db37647178f25 (diff)
downloadmaster-187ad058-a082943b09f4f707990ad0ac6326df8480507f02.tar.gz
master-187ad058-a082943b09f4f707990ad0ac6326df8480507f02.tar.bz2
master-187ad058-a082943b09f4f707990ad0ac6326df8480507f02.zip
rename target/linux/generic-2.6 to generic
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21952 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.35/991-ppc4xx_optimization.patch')
-rw-r--r--target/linux/generic/patches-2.6.35/991-ppc4xx_optimization.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.35/991-ppc4xx_optimization.patch b/target/linux/generic/patches-2.6.35/991-ppc4xx_optimization.patch
new file mode 100644
index 0000000000..0efb777809
--- /dev/null
+++ b/target/linux/generic/patches-2.6.35/991-ppc4xx_optimization.patch
@@ -0,0 +1,31 @@
+Upstream doesn't optimize the kernel and bootwrappers for ppc44x because
+they still want to support gcc 3.3 -- well, we don't.
+
+--- a/arch/powerpc/Makefile
++++ b/arch/powerpc/Makefile
+@@ -123,7 +123,8 @@ ifeq ($(CONFIG_FUNCTION_TRACER),y)
+ KBUILD_CFLAGS += -mno-sched-epilog
+ endif
+
+-cpu-as-$(CONFIG_4xx) += -Wa,-m405
++cpu-as-$(CONFIG_40x) += -Wa,-m405
++cpu-as-$(CONFIG_44x) += -Wa,-m440
+ cpu-as-$(CONFIG_6xx) += -Wa,-maltivec
+ cpu-as-$(CONFIG_POWER4) += -Wa,-maltivec
+ cpu-as-$(CONFIG_E500) += -Wa,-me500
+--- a/arch/powerpc/boot/Makefile
++++ b/arch/powerpc/boot/Makefile
+@@ -38,10 +38,10 @@ BOOTCFLAGS += -I$(obj) -I$(srctree)/$(ob
+ DTS_FLAGS ?= -p 1024
+
+ $(obj)/4xx.o: BOOTCFLAGS += -mcpu=405
+-$(obj)/ebony.o: BOOTCFLAGS += -mcpu=405
++$(obj)/ebony.o: BOOTCFLAGS += -mcpu=440
+ $(obj)/cuboot-hotfoot.o: BOOTCFLAGS += -mcpu=405
+-$(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=405
+-$(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=405
++$(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=440
++$(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=440
+ $(obj)/cuboot-acadia.o: BOOTCFLAGS += -mcpu=405
+ $(obj)/treeboot-walnut.o: BOOTCFLAGS += -mcpu=405
+ $(obj)/virtex405-head.o: BOOTAFLAGS += -mcpu=405