aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-30 20:20:10 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-30 20:20:10 +0000
commit0f8ce34917f48c476636b34b11bf9788822f48f3 (patch)
tree896b92cbc7794f49a3dd6c8c6de16b1111d0e3b4 /target/linux/generic/image
parent5c7193d17b8444ca2c42ddea87b3707e035376f2 (diff)
downloadmaster-187ad058-0f8ce34917f48c476636b34b11bf9788822f48f3.tar.gz
master-187ad058-0f8ce34917f48c476636b34b11bf9788822f48f3.tar.bz2
master-187ad058-0f8ce34917f48c476636b34b11bf9788822f48f3.zip
generic: relocate: make the cacheline size configurable
Different targets have different cache line sizes. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45163 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/image')
-rw-r--r--target/linux/generic/image/relocate/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/generic/image/relocate/Makefile b/target/linux/generic/image/relocate/Makefile
index 500423b63b..5f6ebeb096 100644
--- a/target/linux/generic/image/relocate/Makefile
+++ b/target/linux/generic/image/relocate/Makefile
@@ -22,6 +22,7 @@ BOARD :=
FLASH_OFFS :=
FLASH_MAX :=
PLATFORM :=
+CACHELINE_SIZE := 32
CC := $(CROSS_COMPILE)gcc
LD := $(CROSS_COMPILE)ld
@@ -36,7 +37,8 @@ CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-common -ffreestanding -fhonour-copts \
-mabi=32 -march=mips32r2 \
-Wa,-32 -Wa,-march=mips32r2 -Wa,-mips32r2 -Wa,--trap \
- -DCONFIG_CACHELINE_SIZE=32 -DKERNEL_ADDR=$(KERNEL_ADDR)
+ -DCONFIG_CACHELINE_SIZE=$(CACHELINE_SIZE) \
+ -DKERNEL_ADDR=$(KERNEL_ADDR)
ASFLAGS = $(CFLAGS) -D__ASSEMBLY__