aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/files/fs/yaffs2/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-12-16 07:51:19 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-12-16 07:51:19 +0000
commita8feb12f58ff4bbedfc448cd99107f130bc322a8 (patch)
treec3baa813b2d49c1e5302c7561a89be81af5b3fe0 /target/linux/generic/files/fs/yaffs2/Makefile
parenta8bc7f528ac71cb6b7405c12cc3c1878b2992164 (diff)
downloadmaster-187ad058-a8feb12f58ff4bbedfc448cd99107f130bc322a8.tar.gz
master-187ad058-a8feb12f58ff4bbedfc448cd99107f130bc322a8.tar.bz2
master-187ad058-a8feb12f58ff4bbedfc448cd99107f130bc322a8.zip
kernel: update yaffs code
Use the latest version of the yaffs code. Fetched from the yaffs2 git tree and it is based on the following commit: commit bc76682d93955cfb33051beb503ad9f8a5450578 Merge: 3a8580e ffa781d Author: Charles Manning <cdhmanning@gmail.com> Date: Thu Jul 11 17:46:25 2013 +1200 Merge branch 'master' of ssh://www.aleph1.co.uk/home/aleph1/git/yaffs2 Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39084 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/files/fs/yaffs2/Makefile')
-rw-r--r--target/linux/generic/files/fs/yaffs2/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/generic/files/fs/yaffs2/Makefile b/target/linux/generic/files/fs/yaffs2/Makefile
index fbdbd4a019..f9a9fb1bfd 100644
--- a/target/linux/generic/files/fs/yaffs2/Makefile
+++ b/target/linux/generic/files/fs/yaffs2/Makefile
@@ -4,14 +4,15 @@
obj-$(CONFIG_YAFFS_FS) += yaffs.o
-yaffs-y := yaffs_ecc.o yaffs_vfs_glue.o yaffs_guts.o yaffs_checkptrw.o
+yaffs-y := yaffs_ecc.o yaffs_vfs.o yaffs_guts.o yaffs_checkptrw.o
yaffs-y += yaffs_packedtags1.o yaffs_packedtags2.o yaffs_nand.o
-yaffs-y += yaffs_tagscompat.o yaffs_tagsvalidity.o
-yaffs-y += yaffs_mtdif.o yaffs_mtdif1.o yaffs_mtdif2.o
-yaffs-y += yaffs_nameval.o
+yaffs-y += yaffs_tagscompat.o yaffs_tagsmarshall.o
+yaffs-y += yaffs_mtdif.o
+yaffs-y += yaffs_nameval.o yaffs_attribs.o
yaffs-y += yaffs_allocator.o
yaffs-y += yaffs_yaffs1.o
yaffs-y += yaffs_yaffs2.o
yaffs-y += yaffs_bitmap.o
+yaffs-y += yaffs_summary.o
yaffs-y += yaffs_verify.o