aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/files/drivers/mtd/mtdsplit/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-17 10:40:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-17 10:40:51 +0000
commitde23a020f3d3b08194e5ac0141b8d64bb766893b (patch)
tree1c63604cb1d843b22a320fc2dec612c55fd6a800 /target/linux/generic/files/drivers/mtd/mtdsplit/Makefile
parentdf21e31604d9878d6a8c80bf11445dcf643b0f8d (diff)
downloadmaster-187ad058-de23a020f3d3b08194e5ac0141b8d64bb766893b.tar.gz
master-187ad058-de23a020f3d3b08194e5ac0141b8d64bb766893b.tar.bz2
master-187ad058-de23a020f3d3b08194e5ac0141b8d64bb766893b.zip
kernel: mtdsplit: add support for brnImages
This adds brnImage (used with the brnboot bootloader) firmware parsing support. brnboot verifies the integrity of the firmware stored on the "Code Image" partitions by looking at the 12 byte footer at the very end of the partition. This footer contains the checksum of the original brnImage (kernel + rootfs/squashfs) and must not be touched (by our JFFS2 rootfs_data - otherwise the image will not be bootable anymore). Big thanks to Mathias Kresin for analyzing the brnImage structure and finding out the information how to keep images valid even when adding a nested rootfs_data partition. Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48261 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/files/drivers/mtd/mtdsplit/Makefile')
-rw-r--r--target/linux/generic/files/drivers/mtd/mtdsplit/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/generic/files/drivers/mtd/mtdsplit/Makefile b/target/linux/generic/files/drivers/mtd/mtdsplit/Makefile
index e09476bc20..ca24c717dc 100644
--- a/target/linux/generic/files/drivers/mtd/mtdsplit/Makefile
+++ b/target/linux/generic/files/drivers/mtd/mtdsplit/Makefile
@@ -6,3 +6,4 @@ obj-$(CONFIG_MTD_SPLIT_FIT_FW) += mtdsplit_fit.o
obj-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
obj-$(CONFIG_MTD_SPLIT_TPLINK_FW) += mtdsplit_tplink.o
obj-$(CONFIG_MTD_SPLIT_TRX_FW) += mtdsplit_trx.o
+obj-$(CONFIG_MTD_SPLIT_BRNIMAGE_FW) += mtdsplit_brnimage.o