aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches/010-disable_old_squashfs_compatibility.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2006-03-21 13:41:09 +0000
committerImre Kaloz <kaloz@openwrt.org>2006-03-21 13:41:09 +0000
commite8fe40d9ca188e0cd62e737d1d89dc5d99e9f08b (patch)
tree209fe66ea4939dc81d09718f3182bdaf68258e49 /target/linux/generic-2.6/patches/010-disable_old_squashfs_compatibility.patch
parent38db67c9bc4537bf42dfe138b590aa895d9d1be8 (diff)
downloadmaster-187ad058-e8fe40d9ca188e0cd62e737d1d89dc5d99e9f08b.tar.gz
master-187ad058-e8fe40d9ca188e0cd62e737d1d89dc5d99e9f08b.tar.bz2
master-187ad058-e8fe40d9ca188e0cd62e737d1d89dc5d99e9f08b.zip
upgrade to squashfs 3.0
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3431 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches/010-disable_old_squashfs_compatibility.patch')
-rw-r--r--target/linux/generic-2.6/patches/010-disable_old_squashfs_compatibility.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches/010-disable_old_squashfs_compatibility.patch b/target/linux/generic-2.6/patches/010-disable_old_squashfs_compatibility.patch
new file mode 100644
index 0000000000..1b8b61a8ea
--- /dev/null
+++ b/target/linux/generic-2.6/patches/010-disable_old_squashfs_compatibility.patch
@@ -0,0 +1,22 @@
+diff -Nur linux-2.6.16/fs/squashfs/Makefile linux-2.6.16-owrt/fs/squashfs/Makefile
+--- linux-2.6.16/fs/squashfs/Makefile 2006-03-21 13:50:31.000000000 +0100
++++ linux-2.6.16-owrt/fs/squashfs/Makefile 2006-03-21 13:51:09.000000000 +0100
+@@ -4,5 +4,4 @@
+
+ obj-$(CONFIG_SQUASHFS) += squashfs.o
+ squashfs-y += inode.o
+-squashfs-y += squashfs2_0.o
+ squashfs-y += LzmaDecode.o
+diff -Nur linux-2.6.16/fs/squashfs/squashfs.h linux-2.6.16-owrt/fs/squashfs/squashfs.h
+--- linux-2.6.16/fs/squashfs/squashfs.h 2006-03-21 10:55:59.000000000 +0100
++++ linux-2.6.16-owrt/fs/squashfs/squashfs.h 2006-03-21 13:50:58.000000000 +0100
+@@ -24,6 +24,9 @@
+ #ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
+ #endif
++#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
++#endif
+
+ #ifdef SQUASHFS_TRACE
+ #define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)