aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.34/991-ppc4xx_optimization.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:24:17 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:24:17 +0000
commit29fec42733aec697e4bd5edf0be9f4d803853ef1 (patch)
treeda443108ade7fa374fd71cd77dd7913fc456ba1e /target/linux/generic-2.6/patches-2.6.34/991-ppc4xx_optimization.patch
parent55770a36bd881e16ce586004580ea5f379a58d87 (diff)
downloadmaster-187ad058-29fec42733aec697e4bd5edf0be9f4d803853ef1.tar.gz
master-187ad058-29fec42733aec697e4bd5edf0be9f4d803853ef1.tar.bz2
master-187ad058-29fec42733aec697e4bd5edf0be9f4d803853ef1.zip
generic-2.6: add 2.6.34 preliminary support (patches)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20140 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.34/991-ppc4xx_optimization.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/991-ppc4xx_optimization.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.34/991-ppc4xx_optimization.patch b/target/linux/generic-2.6/patches-2.6.34/991-ppc4xx_optimization.patch
new file mode 100644
index 0000000000..0efb777809
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.34/991-ppc4xx_optimization.patch
@@ -0,0 +1,31 @@
+Upstream doesn't optimize the kernel and bootwrappers for ppc44x because
+they still want to support gcc 3.3 -- well, we don't.
+
+--- a/arch/powerpc/Makefile
++++ b/arch/powerpc/Makefile
+@@ -123,7 +123,8 @@ ifeq ($(CONFIG_FUNCTION_TRACER),y)
+ KBUILD_CFLAGS += -mno-sched-epilog
+ endif
+
+-cpu-as-$(CONFIG_4xx) += -Wa,-m405
++cpu-as-$(CONFIG_40x) += -Wa,-m405
++cpu-as-$(CONFIG_44x) += -Wa,-m440
+ cpu-as-$(CONFIG_6xx) += -Wa,-maltivec
+ cpu-as-$(CONFIG_POWER4) += -Wa,-maltivec
+ cpu-as-$(CONFIG_E500) += -Wa,-me500
+--- a/arch/powerpc/boot/Makefile
++++ b/arch/powerpc/boot/Makefile
+@@ -38,10 +38,10 @@ BOOTCFLAGS += -I$(obj) -I$(srctree)/$(ob
+ DTS_FLAGS ?= -p 1024
+
+ $(obj)/4xx.o: BOOTCFLAGS += -mcpu=405
+-$(obj)/ebony.o: BOOTCFLAGS += -mcpu=405
++$(obj)/ebony.o: BOOTCFLAGS += -mcpu=440
+ $(obj)/cuboot-hotfoot.o: BOOTCFLAGS += -mcpu=405
+-$(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=405
+-$(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=405
++$(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=440
++$(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=440
+ $(obj)/cuboot-acadia.o: BOOTCFLAGS += -mcpu=405
+ $(obj)/treeboot-walnut.o: BOOTCFLAGS += -mcpu=405
+ $(obj)/virtex405-head.o: BOOTAFLAGS += -mcpu=405