aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.33
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-03-11 18:48:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-03-11 18:48:57 +0000
commit3e2f215c02fba8404459c8821ddb69cb4a0a572a (patch)
tree533c9423b6ef63171a36506d8443668c131abd6e /target/linux/generic-2.6/patches-2.6.33
parent2e64f11f6812aac01529f07f332aedd78484a30c (diff)
downloadmaster-187ad058-3e2f215c02fba8404459c8821ddb69cb4a0a572a.tar.gz
master-187ad058-3e2f215c02fba8404459c8821ddb69cb4a0a572a.tar.bz2
master-187ad058-3e2f215c02fba8404459c8821ddb69cb4a0a572a.zip
ar71xx: fix oprofile support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20150 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.33')
-rw-r--r--target/linux/generic-2.6/patches-2.6.33/208-mips_oprofile_fix.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.33/208-mips_oprofile_fix.patch b/target/linux/generic-2.6/patches-2.6.33/208-mips_oprofile_fix.patch
new file mode 100644
index 0000000000..0cbf4ed32b
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.33/208-mips_oprofile_fix.patch
@@ -0,0 +1,48 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -49,7 +49,9 @@ ifneq ($(SUBARCH),$(ARCH))
+ endif
+
+ ifndef CONFIG_FUNCTION_TRACER
+-cflags-y := -ffunction-sections
++ ifndef CONFIG_PROFILING
++ cflags-y := -ffunction-sections
++ endif
+ endif
+ ifdef CONFIG_FUNCTION_GRAPH_TRACER
+ ifndef KBUILD_MCOUNT_RA_ADDRESS
+--- a/arch/mips/oprofile/op_model_mipsxx.c
++++ b/arch/mips/oprofile/op_model_mipsxx.c
+@@ -298,6 +298,11 @@ static void reset_counters(void *arg)
+ }
+ }
+
++static irqreturn_t mipsxx_perfcount_int(int irq, void *dev_id)
++{
++ return mipsxx_perfcount_handler();
++}
++
+ static int __init mipsxx_init(void)
+ {
+ int counters;
+@@ -374,6 +379,10 @@ static int __init mipsxx_init(void)
+ save_perf_irq = perf_irq;
+ perf_irq = mipsxx_perfcount_handler;
+
++ if (cp0_perfcount_irq >= 0)
++ return request_irq(cp0_perfcount_irq, mipsxx_perfcount_int,
++ IRQF_SHARED, "Perfcounter", save_perf_irq);
++
+ return 0;
+ }
+
+@@ -381,6 +390,9 @@ static void mipsxx_exit(void)
+ {
+ int counters = op_model_mipsxx_ops.num_counters;
+
++ if (cp0_perfcount_irq >= 0)
++ free_irq(cp0_perfcount_irq, save_perf_irq);
++
+ counters = counters_per_cpu_to_total(counters);
+ on_each_cpu(reset_counters, (void *)(long)counters, 1);
+