aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch
diff options
context:
space:
mode:
authorMatteo Croce <matteo@openwrt.org>2010-02-28 15:20:00 +0000
committerMatteo Croce <matteo@openwrt.org>2010-02-28 15:20:00 +0000
commit7cce85a44a0cdf826c5f1850c0465e51c6b346a2 (patch)
treec49ac1a86a7262dd17d7b4c0af3c151c37338619 /target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch
parent4c71989564cb66bffc1cd9f075f0c776282b61e4 (diff)
downloadmaster-187ad058-7cce85a44a0cdf826c5f1850c0465e51c6b346a2.tar.gz
master-187ad058-7cce85a44a0cdf826c5f1850c0465e51c6b346a2.tar.bz2
master-187ad058-7cce85a44a0cdf826c5f1850c0465e51c6b346a2.zip
kernel: add 2.6.33 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19905 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch b/target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch
new file mode 100644
index 0000000000..a4793cb63b
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.33/690-phy_rtl8306.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -110,6 +110,10 @@ config AR8216_PHY
+ tristate "Driver for Atheros AR8216 switches"
+ select SWCONFIG
+
++config RTL8306_PHY
++ tristate "Driver for Realtek RTL8306S switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
++obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o