aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.33/620-phy_adm6996.patch
diff options
context:
space:
mode:
authorMatteo Croce <matteo@openwrt.org>2010-02-28 15:20:00 +0000
committerMatteo Croce <matteo@openwrt.org>2010-02-28 15:20:00 +0000
commit7cce85a44a0cdf826c5f1850c0465e51c6b346a2 (patch)
treec49ac1a86a7262dd17d7b4c0af3c151c37338619 /target/linux/generic-2.6/patches-2.6.33/620-phy_adm6996.patch
parent4c71989564cb66bffc1cd9f075f0c776282b61e4 (diff)
downloadmaster-187ad058-7cce85a44a0cdf826c5f1850c0465e51c6b346a2.tar.gz
master-187ad058-7cce85a44a0cdf826c5f1850c0465e51c6b346a2.tar.bz2
master-187ad058-7cce85a44a0cdf826c5f1850c0465e51c6b346a2.zip
kernel: add 2.6.33 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19905 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.33/620-phy_adm6996.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.33/620-phy_adm6996.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.33/620-phy_adm6996.patch b/target/linux/generic-2.6/patches-2.6.33/620-phy_adm6996.patch
new file mode 100644
index 0000000000..b3e469a8d6
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.33/620-phy_adm6996.patch
@@ -0,0 +1,24 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -88,6 +88,11 @@ config LSI_ET1011C_PHY
+ ---help---
+ Supports the LSI ET1011C PHY.
+
++config ADM6996_PHY
++ tristate "Driver for ADM6996 switches"
++ ---help---
++ Currently supports the ADM6996F switch
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -13,6 +13,7 @@ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
+ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
++obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o