aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.32/970-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-11-03 10:49:27 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-11-03 10:49:27 +0000
commit6f4a7596370aaa61dc6f605007d72b1813e1f4f8 (patch)
tree632d6b87886f34dd23c8563f4abb2ffe58236ff5 /target/linux/generic-2.6/patches-2.6.32/970-ocf_kbuild_integration.patch
parent5b5838be6c2e2c4c637f6fa982dfd35c50904500 (diff)
downloadmaster-187ad058-6f4a7596370aaa61dc6f605007d72b1813e1f4f8.tar.gz
master-187ad058-6f4a7596370aaa61dc6f605007d72b1813e1f4f8.tar.bz2
master-187ad058-6f4a7596370aaa61dc6f605007d72b1813e1f4f8.zip
add preliminary 2.6.32 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18283 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.32/970-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.32/970-ocf_kbuild_integration.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.32/970-ocf_kbuild_integration.patch b/target/linux/generic-2.6/patches-2.6.32/970-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..09ad25236e
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.32/970-ocf_kbuild_integration.patch
@@ -0,0 +1,25 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -810,6 +810,8 @@ config CRYPTO_ANSI_CPRNG
+ ANSI X9.31 A.2.4. Not this option must be enabled if CRYPTO_FIPS
+ is selected
+
++source "crypto/ocf/Kconfig"
++
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -86,6 +86,11 @@ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+ obj-$(CONFIG_CRYPTO_GHASH) += ghash-generic.o
+
+ #
++# OCF
++#
++obj-$(CONFIG_OCF_OCF) += ocf/
++
++#
+ # generic algorithms and the async_tx api
+ #
+ obj-$(CONFIG_XOR_BLOCKS) += xor.o