aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.32/052-lzo_compressed_kernel_for_x86.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-11-17 10:04:41 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-11-17 10:04:41 +0000
commit430b78b80dece21c3b868e94b6d86744f615a147 (patch)
tree335dbf2e018fd2bec73a6a56487de2fa0b4e60e4 /target/linux/generic-2.6/patches-2.6.32/052-lzo_compressed_kernel_for_x86.patch
parent3dfc0a8b3670dc00d4cb0f58f3ac16e44704301e (diff)
downloadmaster-187ad058-430b78b80dece21c3b868e94b6d86744f615a147.tar.gz
master-187ad058-430b78b80dece21c3b868e94b6d86744f615a147.tar.bz2
master-187ad058-430b78b80dece21c3b868e94b6d86744f615a147.zip
replace our arm LZMA loader with the one that goes upstream
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18439 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.32/052-lzo_compressed_kernel_for_x86.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.32/052-lzo_compressed_kernel_for_x86.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.32/052-lzo_compressed_kernel_for_x86.patch b/target/linux/generic-2.6/patches-2.6.32/052-lzo_compressed_kernel_for_x86.patch
new file mode 100644
index 0000000000..ea7d2400ba
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.32/052-lzo_compressed_kernel_for_x86.patch
@@ -0,0 +1,48 @@
+--- a/arch/x86/Kconfig
++++ b/arch/x86/Kconfig
+@@ -49,6 +49,7 @@ config X86
+ select HAVE_KERNEL_GZIP
+ select HAVE_KERNEL_BZIP2
+ select HAVE_KERNEL_LZMA
++ select HAVE_KERNEL_LZO
+ select HAVE_ARCH_KMEMCHECK
+
+ config OUTPUT_FORMAT
+--- a/arch/x86/boot/compressed/Makefile
++++ b/arch/x86/boot/compressed/Makefile
+@@ -4,7 +4,7 @@
+ # create a compressed vmlinux image from the original vmlinux
+ #
+
+-targets := vmlinux.lds vmlinux vmlinux.bin vmlinux.bin.gz vmlinux.bin.bz2 vmlinux.bin.lzma head_$(BITS).o misc.o piggy.o
++targets := vmlinux.lds vmlinux vmlinux.bin vmlinux.bin.gz vmlinux.bin.bz2 vmlinux.bin.lzma vmlinux.bin.lzo head_$(BITS).o misc.o piggy.o
+
+ KBUILD_CFLAGS := -m$(BITS) -D__KERNEL__ $(LINUX_INCLUDE) -O2
+ KBUILD_CFLAGS += -fno-strict-aliasing -fPIC
+@@ -48,10 +48,13 @@ $(obj)/vmlinux.bin.bz2: $(vmlinux.bin.al
+ $(call if_changed,bzip2)
+ $(obj)/vmlinux.bin.lzma: $(vmlinux.bin.all-y) FORCE
+ $(call if_changed,lzma)
++$(obj)/vmlinux.bin.lzo: $(vmlinux.bin.all-y) FORCE
++ $(call if_changed,lzo)
+
+ suffix-$(CONFIG_KERNEL_GZIP) := gz
+ suffix-$(CONFIG_KERNEL_BZIP2) := bz2
+ suffix-$(CONFIG_KERNEL_LZMA) := lzma
++suffix-$(CONFIG_KERNEL_LZO) := lzo
+
+ quiet_cmd_mkpiggy = MKPIGGY $@
+ cmd_mkpiggy = $(obj)/mkpiggy $< > $@ || ( rm -f $@ ; false )
+--- a/arch/x86/boot/compressed/misc.c
++++ b/arch/x86/boot/compressed/misc.c
+@@ -162,6 +162,10 @@ static int lines, cols;
+ #include "../../../../lib/decompress_unlzma.c"
+ #endif
+
++#ifdef CONFIG_KERNEL_LZO
++#include "../../../../lib/decompress_unlzo.c"
++#endif
++
+ static void scroll(void)
+ {
+ int i;