aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.31/970-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-04 20:59:19 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-04 20:59:19 +0000
commit0f34590d5547059b8a8bd1bd3875f2f663fb1e6e (patch)
treee2514d65fed366af6c5f498e58431b2008ccf437 /target/linux/generic-2.6/patches-2.6.31/970-ocf_kbuild_integration.patch
parent98af872a32e530441318bba1b73ed15152db8c83 (diff)
downloadmaster-187ad058-0f34590d5547059b8a8bd1bd3875f2f663fb1e6e.tar.gz
master-187ad058-0f34590d5547059b8a8bd1bd3875f2f663fb1e6e.tar.bz2
master-187ad058-0f34590d5547059b8a8bd1bd3875f2f663fb1e6e.zip
[generic-2.6] update OCF framework to version 20100325
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21356 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.31/970-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/970-ocf_kbuild_integration.patch19
1 files changed, 7 insertions, 12 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.31/970-ocf_kbuild_integration.patch b/target/linux/generic-2.6/patches-2.6.31/970-ocf_kbuild_integration.patch
index a6d86ce44a..61897eb4a6 100644
--- a/target/linux/generic-2.6/patches-2.6.31/970-ocf_kbuild_integration.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/970-ocf_kbuild_integration.patch
@@ -1,25 +1,20 @@
--- a/crypto/Kconfig
+++ b/crypto/Kconfig
-@@ -788,6 +788,8 @@ config CRYPTO_ANSI_CPRNG
- for cryptographic modules. Uses the Algorithm specified in
- ANSI X9.31 A.2.4
-
-+source "crypto/ocf/Kconfig"
-+
+@@ -791,3 +791,6 @@ config CRYPTO_ANSI_CPRNG
source "drivers/crypto/Kconfig"
endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
--- a/crypto/Makefile
+++ b/crypto/Makefile
-@@ -85,6 +85,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+@@ -84,6 +84,8 @@ obj-$(CONFIG_CRYPTO_RNG2) += krng.o
+ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_cprng.o
obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
- #
-+# OCF
-+#
+obj-$(CONFIG_OCF_OCF) += ocf/
+
-+#
+ #
# generic algorithms and the async_tx api
#
- obj-$(CONFIG_XOR_BLOCKS) += xor.o