aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.31/410-gpio_buttons.patch
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2009-08-22 12:46:12 +0000
committerMirko Vogt <mirko@openwrt.org>2009-08-22 12:46:12 +0000
commit8bc9864493c5ba790f68769ed71b54de04ba4ea6 (patch)
treef2e9f1150816b597adc38a4ca8a7a5f14a0909e5 /target/linux/generic-2.6/patches-2.6.31/410-gpio_buttons.patch
parent14dde50efd4eb00edb2ae3f2b8ac1b2ed09604c4 (diff)
downloadmaster-187ad058-8bc9864493c5ba790f68769ed71b54de04ba4ea6.tar.gz
master-187ad058-8bc9864493c5ba790f68769ed71b54de04ba4ea6.tar.bz2
master-187ad058-8bc9864493c5ba790f68769ed71b54de04ba4ea6.zip
add generic patchset levelled up to 2.6.31-rc6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17351 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.31/410-gpio_buttons.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/410-gpio_buttons.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.31/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.31/410-gpio_buttons.patch
new file mode 100644
index 0000000000..688f6fe10f
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.31/410-gpio_buttons.patch
@@ -0,0 +1,31 @@
+--- a/drivers/input/misc/Kconfig
++++ b/drivers/input/misc/Kconfig
+@@ -269,4 +269,21 @@ config INPUT_DM355EVM
+
+ To compile this driver as a module, choose M here: the
+ module will be called dm355evm_keys.
++
++config INPUT_GPIO_BUTTONS
++ tristate "Polled GPIO buttons interface"
++ depends on GENERIC_GPIO
++ select INPUT_POLLDEV
++ help
++ This driver implements support for buttons connected
++ to GPIO pins of various CPUs (and some other chips).
++
++ Say Y here if your device has buttons connected
++ directly to such GPIO pins. Your board-specific
++ setup logic must also provide a platform device,
++ with configuration data saying which GPIOs are used.
++
++ To compile this driver as a module, choose M here: the
++ module will be called gpio-buttons.
++
+ endif
+--- a/drivers/input/misc/Makefile
++++ b/drivers/input/misc/Makefile
+@@ -26,3 +26,4 @@ obj-$(CONFIG_INPUT_TWL4030_PWRBUTTON) +=
+ obj-$(CONFIG_INPUT_UINPUT) += uinput.o
+ obj-$(CONFIG_INPUT_WISTRON_BTNS) += wistron_btns.o
+ obj-$(CONFIG_INPUT_YEALINK) += yealink.o
++obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o