aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.30/670-phy_ip175c.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-06-01 22:14:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-06-01 22:14:11 +0000
commit9cba5fd9c685f60bc2bb1e9094c48c36e5eb2428 (patch)
tree0688adbc269f638e1c9b3b65cbacac61137e7bb4 /target/linux/generic-2.6/patches-2.6.30/670-phy_ip175c.patch
parent90cfc524b6b550c3d9eee212f3dba62689755558 (diff)
downloadmaster-187ad058-9cba5fd9c685f60bc2bb1e9094c48c36e5eb2428.tar.gz
master-187ad058-9cba5fd9c685f60bc2bb1e9094c48c36e5eb2428.tar.bz2
master-187ad058-9cba5fd9c685f60bc2bb1e9094c48c36e5eb2428.zip
add ip175c switch driver patch to 2.6.30
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16287 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.30/670-phy_ip175c.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/670-phy_ip175c.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.30/670-phy_ip175c.patch b/target/linux/generic-2.6/patches-2.6.30/670-phy_ip175c.patch
new file mode 100644
index 0000000000..461df50465
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.30/670-phy_ip175c.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -96,6 +96,10 @@ config ADM6996_PHY
+ config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
+
++config IP175C_PHY
++ tristate "Driver for IC+ IP175C/IP178C switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
++obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o