aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-04-28 13:35:14 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-04-28 13:35:14 +0000
commitb830ff89945d93e7dec4b46f9a38029b80f2c71c (patch)
tree9f391646f3e5cf12683bf4b82c0ad6168042d1cf /target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch
parent2fcc705fc5562b577cdded39e61ef725ee64d124 (diff)
downloadmaster-187ad058-b830ff89945d93e7dec4b46f9a38029b80f2c71c.tar.gz
master-187ad058-b830ff89945d93e7dec4b46f9a38029b80f2c71c.tar.bz2
master-187ad058-b830ff89945d93e7dec4b46f9a38029b80f2c71c.zip
preliminary 2.6.30 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15468 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch
new file mode 100644
index 0000000000..6077906ae3
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.30/410-gpio_buttons.patch
@@ -0,0 +1,30 @@
+--- a/drivers/input/misc/Kconfig
++++ b/drivers/input/misc/Kconfig
+@@ -227,4 +227,20 @@ config INPUT_PCF50633_PMU
+ Say Y to include support for delivering PMU events via input
+ layer on NXP PCF50633.
+
++config INPUT_GPIO_BUTTONS
++ tristate "Polled GPIO buttons interface"
++ depends on GENERIC_GPIO
++ select INPUT_POLLDEV
++ help
++ This driver implements support for buttons connected
++ to GPIO pins of various CPUs (and some other chips).
++
++ Say Y here if your device has buttons connected
++ directly to such GPIO pins. Your board-specific
++ setup logic must also provide a platform device,
++ with configuration data saying which GPIOs are used.
++
++ To compile this driver as a module, choose M here: the
++ module will be called gpio-buttons.
++
+ endif
+--- a/drivers/input/misc/Makefile
++++ b/drivers/input/misc/Makefile
+@@ -22,3 +22,4 @@ obj-$(CONFIG_INPUT_UINPUT) += uinput.o
+ obj-$(CONFIG_INPUT_APANEL) += apanel.o
+ obj-$(CONFIG_INPUT_SGI_BTNS) += sgi_btns.o
+ obj-$(CONFIG_INPUT_PCF50633_PMU) += pcf50633-input.o
++obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o