aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.28/970-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-12-08 13:23:09 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-12-08 13:23:09 +0000
commite5206f9754e62fdbdb54d1998e74cf0d921359f6 (patch)
tree0cb3e4ccf62f00cbc257d6b2d4156e02c342b551 /target/linux/generic-2.6/patches-2.6.28/970-ocf_kbuild_integration.patch
parentdf84ce6c3a2f713403d8cc3cb679d4619302464c (diff)
downloadmaster-187ad058-e5206f9754e62fdbdb54d1998e74cf0d921359f6.tar.gz
master-187ad058-e5206f9754e62fdbdb54d1998e74cf0d921359f6.tar.bz2
master-187ad058-e5206f9754e62fdbdb54d1998e74cf0d921359f6.zip
add generic 2.6.28 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13546 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.28/970-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.28/970-ocf_kbuild_integration.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.28/970-ocf_kbuild_integration.patch b/target/linux/generic-2.6/patches-2.6.28/970-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..9fe19ac710
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.28/970-ocf_kbuild_integration.patch
@@ -0,0 +1,25 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -707,6 +707,8 @@ config CRYPTO_ANSI_CPRNG
+ for cryptographic modules. Uses the Algorithm specified in
+ ANSI X9.31 A.2.4
+
++source "crypto/ocf/Kconfig"
++
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -79,6 +79,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+
+ #
++# OCF
++#
++obj-$(CONFIG_OCF_OCF) += ocf/
++
++#
+ # generic algorithms and the async_tx api
+ #
+ obj-$(CONFIG_XOR_BLOCKS) += xor.o