aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-04 20:59:19 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-04 20:59:19 +0000
commit0f34590d5547059b8a8bd1bd3875f2f663fb1e6e (patch)
treee2514d65fed366af6c5f498e58431b2008ccf437 /target/linux/generic-2.6/patches-2.6.25
parent98af872a32e530441318bba1b73ed15152db8c83 (diff)
downloadmaster-187ad058-0f34590d5547059b8a8bd1bd3875f2f663fb1e6e.tar.gz
master-187ad058-0f34590d5547059b8a8bd1bd3875f2f663fb1e6e.tar.bz2
master-187ad058-0f34590d5547059b8a8bd1bd3875f2f663fb1e6e.zip
[generic-2.6] update OCF framework to version 20100325
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21356 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/971-ocf_20100325.patch (renamed from target/linux/generic-2.6/patches-2.6.25/971-ocf_20080917.patch)46
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/972-ocf_compile_fix.patch11
2 files changed, 18 insertions, 39 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/971-ocf_20080917.patch b/target/linux/generic-2.6/patches-2.6.25/971-ocf_20100325.patch
index 4661bad132..61be88ab84 100644
--- a/target/linux/generic-2.6/patches-2.6.25/971-ocf_20080917.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/971-ocf_20100325.patch
@@ -1,23 +1,3 @@
---- a/crypto/Kconfig
-+++ b/crypto/Kconfig
-@@ -593,3 +593,6 @@ config CRYPTO_LZO
- source "drivers/crypto/Kconfig"
-
- endif # if CRYPTO
-+
-+source "crypto/ocf/Kconfig"
-+
---- a/crypto/Makefile
-+++ b/crypto/Makefile
-@@ -65,6 +65,8 @@ obj-$(CONFIG_CRYPTO_LZO) += lzo.o
-
- obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
-
-+obj-$(CONFIG_OCF_OCF) += ocf/
-+
- #
- # generic algorithms and the async_tx api
- #
--- a/drivers/char/random.c
+++ b/drivers/char/random.c
@@ -129,6 +129,9 @@
@@ -60,9 +40,9 @@
+ */
+void random_input_words(__u32 *buf, size_t wordcount, int ent_count)
+{
-+ add_entropy_words(&input_pool, buf, wordcount);
++ mix_pool_bytes(&input_pool, buf, wordcount*4);
+
-+ credit_entropy_store(&input_pool, ent_count);
++ credit_entropy_bits(&input_pool, ent_count);
+
+ DEBUG_ENT("crediting %d bits => %d\n",
+ ent_count, input_pool.entropy_count);
@@ -108,21 +88,21 @@
/*********************************************************************
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
-@@ -202,6 +202,7 @@ asmlinkage long sys_dup(unsigned int fil
- ret = dupfd(file, 0, 0);
- return ret;
+@@ -136,6 +136,7 @@ static int dupfd(struct file *file, unsi
+
+ return fd;
}
+EXPORT_SYMBOL(sys_dup);
- #define SETFL_MASK (O_APPEND | O_NONBLOCK | O_NDELAY | FASYNC | O_DIRECT | O_NOATIME)
-
+ asmlinkage long sys_dup2(unsigned int oldfd, unsigned int newfd)
+ {
--- a/include/linux/miscdevice.h
+++ b/include/linux/miscdevice.h
@@ -12,6 +12,7 @@
#define APOLLO_MOUSE_MINOR 7
#define PC110PAD_MINOR 9
/*#define ADB_MOUSE_MINOR 10 FIXME OBSOLETE */
-+#define CRYPTODEV_MINOR 70 /* /dev/crypto */
++#define CRYPTODEV_MINOR 70
#define WATCHDOG_MINOR 130 /* Watchdog timer */
#define TEMP_MINOR 131 /* Temperature Sensor */
#define RTC_MINOR 135
@@ -178,3 +158,13 @@
extern void get_random_bytes(void *buf, int nbytes);
void generate_random_uuid(unsigned char uuid_out[16]);
+--- a/kernel/pid.c
++++ b/kernel/pid.c
+@@ -377,6 +377,7 @@ struct task_struct *find_task_by_pid_typ
+ {
+ return pid_task(find_pid_ns(nr, ns), type);
+ }
++EXPORT_SYMBOL(find_task_by_vpid);
+
+ EXPORT_SYMBOL(find_task_by_pid_type_ns);
+
diff --git a/target/linux/generic-2.6/patches-2.6.25/972-ocf_compile_fix.patch b/target/linux/generic-2.6/patches-2.6.25/972-ocf_compile_fix.patch
deleted file mode 100644
index a3fa226814..0000000000
--- a/target/linux/generic-2.6/patches-2.6.25/972-ocf_compile_fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/crypto/ocf/cryptosoft.c
-+++ b/crypto/ocf/cryptosoft.c
-@@ -47,7 +47,7 @@
- #include <linux/mm.h>
- #include <linux/skbuff.h>
- #include <linux/random.h>
--#include <asm/scatterlist.h>
-+#include <linux/scatterlist.h>
-
- #include <cryptodev.h>
- #include <uio.h>