aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-04-19 15:20:44 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-04-19 15:20:44 +0000
commit127d15a775b51296ab6eda47e9b116f988bebd7c (patch)
tree63364c73ceef57da30ee5a6669865d095b09c5bc /target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch
parentbdd7f3c7baeeb20ff5838ca685a3305de7d818ba (diff)
downloadmaster-187ad058-127d15a775b51296ab6eda47e9b116f988bebd7c.tar.gz
master-187ad058-127d15a775b51296ab6eda47e9b116f988bebd7c.tar.bz2
master-187ad058-127d15a775b51296ab6eda47e9b116f988bebd7c.zip
add proper 2.6.25 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10865 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch b/target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..780fd34a5c
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.25/400-ledtrig_morse.patch
@@ -0,0 +1,22 @@
+Index: linux-2.6.23-rc9/drivers/leds/Kconfig
+===================================================================
+--- linux-2.6.23-rc9.orig/drivers/leds/Kconfig 2007-10-02 12:51:05.000000000 +0800
++++ linux-2.6.23-rc9/drivers/leds/Kconfig 2007-10-03 23:43:31.000000000 +0800
+@@ -133,4 +133,8 @@
+ load average.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+Index: linux-2.6.23-rc9/drivers/leds/Makefile
+===================================================================
+--- linux-2.6.23-rc9.orig/drivers/leds/Makefile 2007-10-02 12:51:05.000000000 +0800
++++ linux-2.6.23-rc9/drivers/leds/Makefile 2007-10-03 23:42:24.000000000 +0800
+@@ -22,3 +22,4 @@
+ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
+ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o