aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-05-30 16:30:51 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-05-30 16:30:51 +0000
commit0d62d39c21daa3d3ee6f974ccf3e3ab3008d79c2 (patch)
tree5e3bc42552316a5cdaf8eee331305ff7b55c7bad /target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch
parent2004a63a81f73ab8d3b926815a11119b5b81c071 (diff)
downloadmaster-187ad058-0d62d39c21daa3d3ee6f974ccf3e3ab3008d79c2.tar.gz
master-187ad058-0d62d39c21daa3d3ee6f974ccf3e3ab3008d79c2.tar.bz2
master-187ad058-0d62d39c21daa3d3ee6f974ccf3e3ab3008d79c2.zip
refresh generic 2.6.25 patches to match upstream style
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11296 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch20
1 files changed, 7 insertions, 13 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch b/target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch
index 7add5f5b93..8575368699 100644
--- a/target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/171-netfilter_tarpit.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.25.4/net/netfilter/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/net/netfilter/Kconfig
-+++ linux-2.6.25.4/net/netfilter/Kconfig
-@@ -437,6 +437,23 @@ config NETFILTER_XT_TARGET_CONNSECMARK
+--- a/net/netfilter/Kconfig
++++ b/net/netfilter/Kconfig
+@@ -437,6 +437,23 @@
To compile it as a module, choose M here. If unsure, say N.
@@ -26,11 +24,9 @@ Index: linux-2.6.25.4/net/netfilter/Kconfig
config NETFILTER_XT_TARGET_TCPMSS
tristate '"TCPMSS" target support'
depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
-Index: linux-2.6.25.4/net/netfilter/Makefile
-===================================================================
---- linux-2.6.25.4.orig/net/netfilter/Makefile
-+++ linux-2.6.25.4/net/netfilter/Makefile
-@@ -47,6 +47,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFQUEUE
+--- a/net/netfilter/Makefile
++++ b/net/netfilter/Makefile
+@@ -47,6 +47,7 @@
obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
obj-$(CONFIG_NETFILTER_XT_TARGET_RATEEST) += xt_RATEEST.o
obj-$(CONFIG_NETFILTER_XT_TARGET_SECMARK) += xt_SECMARK.o
@@ -38,10 +34,8 @@ Index: linux-2.6.25.4/net/netfilter/Makefile
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPOPTSTRIP) += xt_TCPOPTSTRIP.o
obj-$(CONFIG_NETFILTER_XT_TARGET_TRACE) += xt_TRACE.o
-Index: linux-2.6.25.4/net/netfilter/xt_TARPIT.c
-===================================================================
--- /dev/null
-+++ linux-2.6.25.4/net/netfilter/xt_TARPIT.c
++++ b/net/netfilter/xt_TARPIT.c
@@ -0,0 +1,279 @@
+/*
+ * Kernel module to capture and hold incoming TCP connections using