aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-02 10:17:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-02 10:17:03 +0000
commit1d4db4520ab1c4e7472a48d14ec641e2ef074b6b (patch)
treeb992b5d551457de6a5d6f53b37b9eec182c68c29 /target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch
parent5c09219b13a1f3695729cc24ac7e8390859a406f (diff)
downloadmaster-187ad058-1d4db4520ab1c4e7472a48d14ec641e2ef074b6b.tar.gz
master-187ad058-1d4db4520ab1c4e7472a48d14ec641e2ef074b6b.tar.bz2
master-187ad058-1d4db4520ab1c4e7472a48d14ec641e2ef074b6b.zip
[kernel] update to 2.6.25.1 and refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11006 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch
index 09248fcdac..c2062f7b0d 100644
--- a/target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.23-rc6/Makefile
+Index: linux-2.6.25.1/Makefile
===================================================================
---- linux-2.6.23-rc6.orig/Makefile 2007-09-21 16:23:55.000000000 +0800
-+++ linux-2.6.23-rc6/Makefile 2007-09-21 16:23:56.000000000 +0800
-@@ -508,6 +508,9 @@
+--- linux-2.6.25.1.orig/Makefile
++++ linux-2.6.25.1/Makefile
+@@ -533,6 +533,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
@@ -10,5 +10,5 @@ Index: linux-2.6.23-rc6/Makefile
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
- CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)