aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-04-15 07:33:43 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-04-15 07:33:43 +0000
commit04b8b09c2f769c74de6373874eb4b1905a6076c8 (patch)
treed9dd1eb2b38c304fc3ab8fbd803fbf21e033e729 /target/linux/generic-2.6/patches-2.6.23
parentfd3378f1e1ade62b38ba64a3630a1cd3581fedd7 (diff)
downloadmaster-187ad058-04b8b09c2f769c74de6373874eb4b1905a6076c8.tar.gz
master-187ad058-04b8b09c2f769c74de6373874eb4b1905a6076c8.tar.bz2
master-187ad058-04b8b09c2f769c74de6373874eb4b1905a6076c8.zip
[package] move spi_gpio driver into the kernel, clean-up SPI modules
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10844 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch b/target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch
new file mode 100644
index 0000000000..aa4e6ee0ac
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch
@@ -0,0 +1,28 @@
+Index: linux-2.6.23.16/drivers/spi/Kconfig
+===================================================================
+--- linux-2.6.23.16.orig/drivers/spi/Kconfig
++++ linux-2.6.23.16/drivers/spi/Kconfig
+@@ -100,6 +100,11 @@ config SPI_BUTTERFLY
+ inexpensive battery powered microcontroller evaluation board.
+ This same cable can be used to flash new firmware.
+
++config SPI_GPIO
++ tristate "GPIO API based bitbanging SPI controller"
++ depends on SPI_MASTER && GENERIC_GPIO && EXPERIMENTAL
++ select SPI_BITBANG
++
+ config SPI_IMX
+ tristate "Freescale iMX SPI controller"
+ depends on SPI_MASTER && ARCH_IMX && EXPERIMENTAL
+Index: linux-2.6.23.16/drivers/spi/Makefile
+===================================================================
+--- linux-2.6.23.16.orig/drivers/spi/Makefile
++++ linux-2.6.23.16/drivers/spi/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.
+ obj-$(CONFIG_SPI_BITBANG) += spi_bitbang.o
+ obj-$(CONFIG_SPI_AU1550) += au1550_spi.o
+ obj-$(CONFIG_SPI_BUTTERFLY) += spi_butterfly.o
++obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
+ obj-$(CONFIG_SPI_IMX) += spi_imx.o
+ obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o
+ obj-$(CONFIG_SPI_PXA2XX) += pxa2xx_spi.o