aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-06-05 17:01:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-06-05 17:01:00 +0000
commit6ffc241131436ea399f2afe5d144c4f5eed79f49 (patch)
treeb842888957a92e8af753d25b456fb0060e3880a8 /target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch
parent1e1f3be69922a72a8cb37ed0b1d93f30c638fe3f (diff)
downloadmaster-187ad058-6ffc241131436ea399f2afe5d144c4f5eed79f49.tar.gz
master-187ad058-6ffc241131436ea399f2afe5d144c4f5eed79f49.tar.bz2
master-187ad058-6ffc241131436ea399f2afe5d144c4f5eed79f49.zip
refresh generic 2.6.23 patches in upstream style
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11366 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch24
1 files changed, 8 insertions, 16 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch b/target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch
index 4a66308ece..fa2f38e547 100644
--- a/target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch
+++ b/target/linux/generic-2.6/patches-2.6.23/922-w1_gpio_driver_backport.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.23.17/drivers/w1/masters/Kconfig
-===================================================================
---- linux-2.6.23.17.orig/drivers/w1/masters/Kconfig
-+++ linux-2.6.23.17/drivers/w1/masters/Kconfig
-@@ -42,5 +42,15 @@ config W1_MASTER_DS1WM
+--- a/drivers/w1/masters/Kconfig
++++ b/drivers/w1/masters/Kconfig
+@@ -42,5 +42,15 @@
in HP iPAQ devices like h5xxx, h2200, and ASIC3-based like
hx4700.
@@ -18,19 +16,15 @@ Index: linux-2.6.23.17/drivers/w1/masters/Kconfig
+
endmenu
-Index: linux-2.6.23.17/drivers/w1/masters/Makefile
-===================================================================
---- linux-2.6.23.17.orig/drivers/w1/masters/Makefile
-+++ linux-2.6.23.17/drivers/w1/masters/Makefile
-@@ -6,3 +6,4 @@ obj-$(CONFIG_W1_MASTER_MATROX) += matro
+--- a/drivers/w1/masters/Makefile
++++ b/drivers/w1/masters/Makefile
+@@ -6,3 +6,4 @@
obj-$(CONFIG_W1_MASTER_DS2490) += ds2490.o
obj-$(CONFIG_W1_MASTER_DS2482) += ds2482.o
obj-$(CONFIG_W1_MASTER_DS1WM) += ds1wm.o
+obj-$(CONFIG_W1_MASTER_GPIO) += w1-gpio.o
-Index: linux-2.6.23.17/drivers/w1/masters/w1-gpio.c
-===================================================================
--- /dev/null
-+++ linux-2.6.23.17/drivers/w1/masters/w1-gpio.c
++++ b/drivers/w1/masters/w1-gpio.c
@@ -0,0 +1,124 @@
+/*
+ * w1-gpio - GPIO w1 bus master driver
@@ -156,10 +150,8 @@ Index: linux-2.6.23.17/drivers/w1/masters/w1-gpio.c
+MODULE_DESCRIPTION("GPIO w1 bus master driver");
+MODULE_AUTHOR("Ville Syrjala <syrjala@sci.fi>");
+MODULE_LICENSE("GPL");
-Index: linux-2.6.23.17/include/linux/w1-gpio.h
-===================================================================
--- /dev/null
-+++ linux-2.6.23.17/include/linux/w1-gpio.h
++++ b/include/linux/w1-gpio.h
@@ -0,0 +1,23 @@
+/*
+ * w1-gpio interface to platform code