aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.22/004-extra_optimization.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-16 01:56:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-16 01:56:04 +0000
commitf46b6a019569e69dfb8a7060e7f36d01e5eedd03 (patch)
tree7a8919b2830b1c51b5dfe7742261a08168b118a2 /target/linux/generic-2.6/patches-2.6.22/004-extra_optimization.patch
parent97ca42e813d5a0a03bd1a70576375dad8469044a (diff)
downloadmaster-187ad058-f46b6a019569e69dfb8a7060e7f36d01e5eedd03.tar.gz
master-187ad058-f46b6a019569e69dfb8a7060e7f36d01e5eedd03.tar.bz2
master-187ad058-f46b6a019569e69dfb8a7060e7f36d01e5eedd03.zip
prepare for the transition to linux 2.6.22 - make it possible to override the kernel version in the target makefile
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7644 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.22/004-extra_optimization.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.22/004-extra_optimization.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.22/004-extra_optimization.patch b/target/linux/generic-2.6/patches-2.6.22/004-extra_optimization.patch
new file mode 100644
index 0000000000..57bea7ea50
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.22/004-extra_optimization.patch
@@ -0,0 +1,13 @@
+diff -urN linux-2.6.21.1.old/Makefile linux-2.6.21.1.dev/Makefile
+--- linux-2.6.21.1.old/Makefile 2007-04-27 23:49:26.000000000 +0200
++++ linux-2.6.21.1.dev/Makefile 2007-05-26 19:14:22.967804016 +0200
+@@ -507,6 +507,9 @@
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+