aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-08 19:33:57 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-08 19:33:57 +0000
commit3bb939ab30234ed985817d438e0e01b8b126b3d1 (patch)
treef3fc6001f5b20a75470276c236e0b595d3e9744e /target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch
parent39a9e851a7ef08af339421d4978a09150772f9ec (diff)
downloadmaster-187ad058-3bb939ab30234ed985817d438e0e01b8b126b3d1.tar.gz
master-187ad058-3bb939ab30234ed985817d438e0e01b8b126b3d1.tar.bz2
master-187ad058-3bb939ab30234ed985817d438e0e01b8b126b3d1.zip
[kernel] generic-2.6/2.6.21: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14453 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch16
1 files changed, 5 insertions, 11 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch b/target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch
index a686bd3d6f..bc86a94fe4 100644
--- a/target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch
+++ b/target/linux/generic-2.6/patches-2.6.21/171-netfilter_tarpit.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.21.7/net/netfilter/Kconfig
-===================================================================
---- linux-2.6.21.7.orig/net/netfilter/Kconfig
-+++ linux-2.6.21.7/net/netfilter/Kconfig
+--- a/net/netfilter/Kconfig
++++ b/net/netfilter/Kconfig
@@ -414,6 +414,23 @@ config NETFILTER_XT_TARGET_CONNSECMARK
To compile it as a module, choose M here. If unsure, say N.
@@ -26,10 +24,8 @@ Index: linux-2.6.21.7/net/netfilter/Kconfig
config NETFILTER_XT_TARGET_TCPMSS
tristate '"TCPMSS" target support'
depends on NETFILTER_XTABLES && (IPV6 || IPV6=n)
-Index: linux-2.6.21.7/net/netfilter/Makefile
-===================================================================
---- linux-2.6.21.7.orig/net/netfilter/Makefile
-+++ linux-2.6.21.7/net/netfilter/Makefile
+--- a/net/netfilter/Makefile
++++ b/net/netfilter/Makefile
@@ -45,6 +45,7 @@ obj-$(CONFIG_NETFILTER_XT_TARGET_NFQUEUE
obj-$(CONFIG_NETFILTER_XT_TARGET_NFLOG) += xt_NFLOG.o
obj-$(CONFIG_NETFILTER_XT_TARGET_NOTRACK) += xt_NOTRACK.o
@@ -38,10 +34,8 @@ Index: linux-2.6.21.7/net/netfilter/Makefile
obj-$(CONFIG_NETFILTER_XT_TARGET_TCPMSS) += xt_TCPMSS.o
obj-$(CONFIG_NETFILTER_XT_TARGET_CONNSECMARK) += xt_CONNSECMARK.o
obj-$(CONFIG_NETFILTER_XT_TARGET_CHAOS) += xt_CHAOS.o
-Index: linux-2.6.21.7/net/netfilter/xt_TARPIT.c
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/net/netfilter/xt_TARPIT.c
++++ b/net/netfilter/xt_TARPIT.c
@@ -0,0 +1,280 @@
+/*
+ * Kernel module to capture and hold incoming TCP connections using