aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.21/002-lzma_decompress.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-08 19:33:57 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-08 19:33:57 +0000
commit3bb939ab30234ed985817d438e0e01b8b126b3d1 (patch)
treef3fc6001f5b20a75470276c236e0b595d3e9744e /target/linux/generic-2.6/patches-2.6.21/002-lzma_decompress.patch
parent39a9e851a7ef08af339421d4978a09150772f9ec (diff)
downloadmaster-187ad058-3bb939ab30234ed985817d438e0e01b8b126b3d1.tar.gz
master-187ad058-3bb939ab30234ed985817d438e0e01b8b126b3d1.tar.bz2
master-187ad058-3bb939ab30234ed985817d438e0e01b8b126b3d1.zip
[kernel] generic-2.6/2.6.21: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14453 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.21/002-lzma_decompress.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.21/002-lzma_decompress.patch14
1 files changed, 4 insertions, 10 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.21/002-lzma_decompress.patch b/target/linux/generic-2.6/patches-2.6.21/002-lzma_decompress.patch
index e4a00692f2..5d4e83fb17 100644
--- a/target/linux/generic-2.6/patches-2.6.21/002-lzma_decompress.patch
+++ b/target/linux/generic-2.6/patches-2.6.21/002-lzma_decompress.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.21.7/include/linux/LzmaDecode.h
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/include/linux/LzmaDecode.h
++++ b/include/linux/LzmaDecode.h
@@ -0,0 +1,100 @@
+/*
+ LzmaDecode.h
@@ -103,10 +101,8 @@ Index: linux-2.6.21.7/include/linux/LzmaDecode.h
+ UInt32 *outSizeProcessed);
+
+#endif
-Index: linux-2.6.21.7/lib/LzmaDecode.c
-===================================================================
--- /dev/null
-+++ linux-2.6.21.7/lib/LzmaDecode.c
++++ b/lib/LzmaDecode.c
@@ -0,0 +1,663 @@
+/*
+ LzmaDecode.c
@@ -771,10 +767,8 @@ Index: linux-2.6.21.7/lib/LzmaDecode.c
+ *outSizeProcessed = nowPos;
+ return LZMA_RESULT_OK;
+}
-Index: linux-2.6.21.7/lib/Makefile
-===================================================================
---- linux-2.6.21.7.orig/lib/Makefile
-+++ linux-2.6.21.7/lib/Makefile
+--- a/lib/Makefile
++++ b/lib/Makefile
@@ -12,7 +12,7 @@ lib-$(CONFIG_SMP) += cpumask.o
lib-y += kobject.o kref.o kobject_uevent.o klist.o