aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/gemini/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-05-13 10:59:59 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-05-13 10:59:59 +0000
commita07be1b61e0322de33a193717288e31fc217365d (patch)
tree746badadf18033ad335ce1969f8d3c5946dc91eb /target/linux/gemini/image
parentb0b58d2d19d9f60eb1d4aa791ae30b3743bcf5e3 (diff)
downloadmaster-187ad058-a07be1b61e0322de33a193717288e31fc217365d.tar.gz
master-187ad058-a07be1b61e0322de33a193717288e31fc217365d.tar.bz2
master-187ad058-a07be1b61e0322de33a193717288e31fc217365d.zip
workaround a bootloader bug on the WBD111
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15818 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/gemini/image')
-rw-r--r--target/linux/gemini/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index 6fb7750649..fc69ffcc81 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -14,7 +14,9 @@ define Image/Prepare
endef
define Image/BuildKernel
- cp $(KDIR)/openwrt-$(BOARD)-wbd111-zImage $(BIN_DIR)/openwrt-$(BOARD)-wbd111-zImage
+# workaround the bootloader's bug with extra nops
+ echo -en "\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1" > $(BIN_DIR)/openwrt-$(BOARD)-wbd111-zImage
+ cat $(KDIR)/openwrt-$(BOARD)-wbd111-zImage >> $(BIN_DIR)/openwrt-$(BOARD)-wbd111-zImage
endef
define Image/Build/jffs2-64k