aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/etrax/profiles
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-06 16:27:37 +0000
commit92558d67a463bfbb351d30e28648de03b635f024 (patch)
treea5d41b991a151e72663527a96fbc6c494565d65c /target/linux/etrax/profiles
parente1dbce411cd2a3a067f387cee011cd889486a07d (diff)
downloadmaster-187ad058-92558d67a463bfbb351d30e28648de03b635f024.tar.gz
master-187ad058-92558d67a463bfbb351d30e28648de03b635f024.tar.bz2
master-187ad058-92558d67a463bfbb351d30e28648de03b635f024.zip
strip the kernel version suffix from target directories, except for brcm-2.4 (the -2.4 will be included in the board name here). CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8653 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/etrax/profiles')
-rw-r--r--target/linux/etrax/profiles/100-generic.mk16
-rw-r--r--target/linux/etrax/profiles/101-vhdl-nofb.mk17
2 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/etrax/profiles/100-generic.mk b/target/linux/etrax/profiles/100-generic.mk
new file mode 100644
index 0000000000..9d0fc72f88
--- /dev/null
+++ b/target/linux/etrax/profiles/100-generic.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/default
+ NAME:=Normal (default)
+endef
+
+define Profile/default/Description
+ Normal Foxboard setup (no vhdl)
+endef
+$(eval $(call Profile,default))
+
diff --git a/target/linux/etrax/profiles/101-vhdl-nofb.mk b/target/linux/etrax/profiles/101-vhdl-nofb.mk
new file mode 100644
index 0000000000..620db4209a
--- /dev/null
+++ b/target/linux/etrax/profiles/101-vhdl-nofb.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/vhdl_no_fb
+ NAME:=FOXVHDL no fb
+# PACKAGES:=kmod-madwifi
+endef
+
+define Profile/vhdl_no_fb/Description
+ Setup the Foxboard for FOXVHDL support with no framebuffer
+endef
+$(eval $(call Profile,vhdl_no_fb))
+