aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/coldfire/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-06-21 18:34:07 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-06-21 18:34:07 +0000
commit0609b66c2c388b7ce5536f4c0a1b14bf617685d2 (patch)
tree39c068bde6937766b91ac60f5157e79c1c8a89c1 /target/linux/coldfire/Makefile
parentfc6e01ad10f76d4c9273a707b8ffb6eae48236b1 (diff)
downloadmaster-187ad058-0609b66c2c388b7ce5536f4c0a1b14bf617685d2.tar.gz
master-187ad058-0609b66c2c388b7ce5536f4c0a1b14bf617685d2.tar.bz2
master-187ad058-0609b66c2c388b7ce5536f4c0a1b14bf617685d2.zip
add preliminary coldfire v4e support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16538 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/coldfire/Makefile')
-rw-r--r--target/linux/coldfire/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/coldfire/Makefile b/target/linux/coldfire/Makefile
new file mode 100644
index 0000000000..0d2963400f
--- /dev/null
+++ b/target/linux/coldfire/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=m68k
+BOARD:=coldfire
+BOARDNAME:=Freescale Coldfire v4e
+FEATURES:=squashfs broken
+
+LINUX_VERSION:=2.6.25.20
+LINUX_KARCH:=m68k
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for ColdFire v4e boards
+endef
+
+$(eval $(call BuildTarget))