aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns3xxx/patches-3.3/070-i2c_support.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-11-12 09:18:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-11-12 09:18:00 +0000
commit29fb5ae7927dae81d76acd79ee8c3f6bee5fd099 (patch)
tree97b650ca1cf4ee2701cbd835e0fcf87dc20e0b8a /target/linux/cns3xxx/patches-3.3/070-i2c_support.patch
parent7a955260a68b62c4c769b79bb22c545019c98d3d (diff)
downloadmaster-187ad058-29fb5ae7927dae81d76acd79ee8c3f6bee5fd099.tar.gz
master-187ad058-29fb5ae7927dae81d76acd79ee8c3f6bee5fd099.tar.bz2
master-187ad058-29fb5ae7927dae81d76acd79ee8c3f6bee5fd099.zip
[cns3xxx]: reorder, rename and refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34169 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns3xxx/patches-3.3/070-i2c_support.patch')
-rw-r--r--target/linux/cns3xxx/patches-3.3/070-i2c_support.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/cns3xxx/patches-3.3/070-i2c_support.patch b/target/linux/cns3xxx/patches-3.3/070-i2c_support.patch
new file mode 100644
index 0000000000..df7ceaceba
--- /dev/null
+++ b/target/linux/cns3xxx/patches-3.3/070-i2c_support.patch
@@ -0,0 +1,31 @@
+--- a/drivers/i2c/busses/Kconfig
++++ b/drivers/i2c/busses/Kconfig
+@@ -326,6 +326,18 @@ config I2C_BLACKFIN_TWI_CLK_KHZ
+ help
+ The unit of the TWI clock is kHz.
+
++config I2C_CNS3XXX
++ tristate "Cavium CNS3xxx I2C driver"
++ depends on ARCH_CNS3XXX
++ help
++ Support for Cavium CNS3xxx I2C controller driver.
++
++ This driver can also be built as a module. If so, the module
++ will be called i2c-cns3xxx.
++
++ Please note that this driver might be needed to bring up other
++ devices such as Cavium CNS3xxx Ethernet.
++
+ config I2C_CPM
+ tristate "Freescale CPM1 or CPM2 (MPC8xx/826x)"
+ depends on (CPM1 || CPM2) && OF_I2C
+--- a/drivers/i2c/busses/Makefile
++++ b/drivers/i2c/busses/Makefile
+@@ -83,6 +83,7 @@ obj-$(CONFIG_I2C_ELEKTOR) += i2c-elektor
+ obj-$(CONFIG_I2C_PCA_ISA) += i2c-pca-isa.o
+ obj-$(CONFIG_I2C_SIBYTE) += i2c-sibyte.o
+ obj-$(CONFIG_I2C_STUB) += i2c-stub.o
++obj-$(CONFIG_I2C_CNS3XXX) += i2c-cns3xxx.o
+ obj-$(CONFIG_SCx200_ACB) += scx200_acb.o
+ obj-$(CONFIG_SCx200_I2C) += scx200_i2c.o
+