aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns21xx/patches-3.7/003-arm-introduce-fa-platform.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-12-20 14:51:17 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-12-20 14:51:17 +0000
commit88ab58eb94865c9e7b873706009fc8d1faaab2c8 (patch)
treefc6e5a30a4e194399cc4fa2970fb4e3f93cf7e97 /target/linux/cns21xx/patches-3.7/003-arm-introduce-fa-platform.patch
parenta7efd844b7ca413852d3e504744528dd3970e657 (diff)
downloadmaster-187ad058-88ab58eb94865c9e7b873706009fc8d1faaab2c8.tar.gz
master-187ad058-88ab58eb94865c9e7b873706009fc8d1faaab2c8.tar.bz2
master-187ad058-88ab58eb94865c9e7b873706009fc8d1faaab2c8.zip
cns21xx: add support for 3.7
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34801 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns21xx/patches-3.7/003-arm-introduce-fa-platform.patch')
-rw-r--r--target/linux/cns21xx/patches-3.7/003-arm-introduce-fa-platform.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/target/linux/cns21xx/patches-3.7/003-arm-introduce-fa-platform.patch b/target/linux/cns21xx/patches-3.7/003-arm-introduce-fa-platform.patch
new file mode 100644
index 0000000000..13511eff51
--- /dev/null
+++ b/target/linux/cns21xx/patches-3.7/003-arm-introduce-fa-platform.patch
@@ -0,0 +1,47 @@
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -1129,10 +1129,15 @@ source "arch/arm/plat-versatile/Kconfig"
+
+ source "arch/arm/mach-w90x900/Kconfig"
+
++source "arch/arm/plat-fa/Kconfig"
++
+ # Definitions to make life easier
+ config ARCH_ACORN
+ bool
+
++config PLAT_FA
++ bool
++
+ config PLAT_IOP
+ bool
+ select GENERIC_CLOCKEVENTS
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
+@@ -200,6 +200,7 @@ plat-$(CONFIG_ARCH_MXC) += mxc
+ plat-$(CONFIG_ARCH_OMAP) += omap
+ plat-$(CONFIG_ARCH_S3C64XX) += samsung
+ plat-$(CONFIG_ARCH_ZYNQ) += versatile
++plat-$(CONFIG_PLAT_FA) += fa
+ plat-$(CONFIG_PLAT_IOP) += iop
+ plat-$(CONFIG_PLAT_NOMADIK) += nomadik
+ plat-$(CONFIG_PLAT_ORION) += orion
+--- /dev/null
++++ b/arch/arm/plat-fa/Makefile
+@@ -0,0 +1,10 @@
++#
++# Makefile for the linux kernel.
++#
++
++obj-y :=
++
++obj-m :=
++obj-n :=
++obj- :=
++
+--- /dev/null
++++ b/arch/arm/plat-fa/Kconfig
+@@ -0,0 +1,3 @@
++if PLAT_FA
++
++endif