aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns21xx/modules.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-13 15:38:42 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-13 15:38:42 +0000
commitdb84e9c3b2008304adae9d7bbef3ade0a8a99846 (patch)
tree905cc69ed19f409cde6fed6d6eb2a1952dcbf9f3 /target/linux/cns21xx/modules.mk
parent6a9f90c0c7488ace03cd63bb5e579ab431c9a684 (diff)
downloadmaster-187ad058-db84e9c3b2008304adae9d7bbef3ade0a8a99846.tar.gz
master-187ad058-db84e9c3b2008304adae9d7bbef3ade0a8a99846.tar.bz2
master-187ad058-db84e9c3b2008304adae9d7bbef3ade0a8a99846.zip
cns21xx: make cns21xx-ehci a separate driver
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37968 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cns21xx/modules.mk')
-rw-r--r--target/linux/cns21xx/modules.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/cns21xx/modules.mk b/target/linux/cns21xx/modules.mk
new file mode 100644
index 0000000000..9882ee8c10
--- /dev/null
+++ b/target/linux/cns21xx/modules.mk
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2103 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/usb2-cns21xx
+ TITLE:=Support for the built-in EHCI controller of the CNS21xx SoCs
+ DEPENDS:=@TARGET_cns21xx +kmod-usb2
+ KCONFIG:=CONFIG_USB_EHCI_CNS21XX
+ FILES:=$(LINUX_DIR)/drivers/usb/host/ehci-cns21xx.ko
+ AUTOLOAD:=$(call AutoLoad,41,ehci-cns21xx,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb2-cns21xx/description
+ Kernel support for the built-in EHCI controller of the CNS21xx SoCs.
+endef
+
+$(eval $(call KernelPackage,usb2-cns21xx))
+
+